• 11
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I have an app published to the Google Play store. I can deploy to the device (Google Pixel running Pie) without issue through Android Studio, but when I go to the page for the app (same version) that is published in the store, it says my device is not compatible.

This is frustrating because 1) the app works perfectly fine when I install it through Android Studio and 2) the play store gives me no feedback as to why my device is allegedly incompatible.

I've tried clearing the Google Play Store cache multiple times as I've seen suggested. However, this issue seems to affect other devices on Android 8+ and I have no clue as to why.

Is there any way to get feedback from Google as to why a device is incompatible?