• 5
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

When bumping my Android Gradle Plugin dependency (from 3.2.1 -> 3.3.x) I started seeing this problem:

D8: Program type already present: android.support.v4.media.RatingCompat$1

This class is found in: com.android.support:support-media-compat As suggested here https://developer.android.com/jetpack/androidx/migrate I have added an explicit dependency to the AndroidX version of the lib: androidx.media:media.

This doesn't work (same issue).

Then I do:

gradlew app:dependencies

I see that com.android.support:support-media-compat is a transitive dependency coming from com.google.android.gms:play-services-analytics (16.0.7, latest that I know of).

I have also tried excluding the transitive dependency:

implementation ('com.google.android.gms:play-services-analytics:16.0.7') {
    exclude group: 'com.android.support', module: 'support-v4'
}

But this doesn't work (the support-v4 dependency still shows up as a transitive dependency).

My versions

  1. com.android.tools.build:gradle:3.3.1
  2. Gradle 5.2.1

Gradle properties:

android.useAndroidX=true
android.enableJetifier=false

Any suggestions?

You should be setting:

android.enableJetifier=true

so that transitive dependencies are converted for you.

  • 1
Reply Report
      • 1
    • Enabling jetifier revealed a test library (org.robolectric:shadows-supportv4:4.1) causing issues and more classes that needed to be converted into Androidx. After doing this it all worked.