• 14
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

VSCode's debugging mode always stop at first line

I am using vscode for python development. I sometimes use debug running mode, and vscode always stop at first line even if there are no breakpoints. I attached a screenshot of this phenomenon. It's a little annoying and I want to skip this. Are there any ways to skip this?

My Env

  • Code Runner 0.6.5
  • MagicPython 1.0.3
  • Python 0.5.5
  • Python for VSCode

enter image description here

The launch.json file has the setting "stopOnEntry":true. Change this to false to prevent this.

The docs for this can be found https://code.visualstudio.com/docs/python/debugging#_stoponentry

  • 46
Reply Report
    • Is there a way I can set it to be false on default? I hate having to reset this on every new configuration I run
      • 2
    • What I do is use the Ctrl + H keyboard shortcut to replace all the "stopOnEntry": true entries with "stopOnEntry": false. I don't think there is a way to set it by default.

Trending Tags