./configure \
    --with-apxs2=/usr/local/apache/bin/apxs \
    --prefix=/usr/local/apache/php \
    --with-config-file-path=/usr/local/apache/php
make && make install

I see no critical errors during the configuration, and none during installation.

Apache is installed at /usr/local/apache, and the apxs has been verified to be correct.

/usr/local/apache/php is not being created and neither is libphp5.so being generated anywhere.

I'm installing 5.2.17 on centos.

EDIT: Here's the full configure command:

./configure \
    --with-apxs2=/usr/local/apache/bin/apxs \
    --with-mysql \
    --prefix=/usr/local/apache/php \
    --with-config-file-path=/usr/local/apache/php \
    --enable-force-cgi-redirect \
    --disable-cgi \
    --with-openssl \
    --with-mcrypt \
    --with-gd \
    --with-pdo-mysql \
    --without-sqlite \
    --without-sqlite3 \
    --enable-pdo \
    --without-pdo-sqlite \
    --with-zlib \
    --with-gettext \
    --with-gdbm \
    --enable-pcnlt \
    --with-curl
Answer

As per the php INSTALL file (which I can't fault you for not reading in its entirety... I spent an hour on google before sitting down and reading the whole thing), you need to make sure apache is installed with

./configure --enable-so

before configuring and making php with

./configure --with-apxs2=/usr/local/apache2/bin/apxs 
  • 15
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags

Related Questions