• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Cannot find PHPUnit in include path phpstorm

Cannot find PHPUnit in include path is the error message I get when I try to run my code in phpstorm.

In the PHP Settings, my PHP level language is 5.4 (traits, short array syntax, etc.) and interpreter is Name(5.4.7) where Name is user defined.

The error appears when I try to run the code and the exact message is this:

C:\xampp2\php\php.exe C:\Users\DELL\AppData\Local\Temp\ide-phpunit.php --no-configuration

C:\xampp2\htdocs\ft-website

Testing started at 2:34 PM ...

Process finished with exit code 1

Cannot find PHPUnit in include path (.;C:\xampp2\php\PEAR)`

      • 2
    • You should do exactly as error message says: add the path where PHPUnit files are located to the include_path config variable in your php.ini
      • 1
    • Is PHPUnit actually installed in C: mpp2phpPEAR? The best way to go would be to either install it there using PEAR, or adjust your PHP include path to a PHPUnit installation at another location.

Just encountered this problem myself.

I'm unsure why it is unable to find PHPUnit in the include path (despite the fact that it is there, albeit in all lowercase).

I got around this by changing my IntelliJ Preferences for PHPUnit (under PHP --> PHPUnit). I changed the PHPUnit library settings to Use custom loader and then specified the path to the phpunit executable. On my mac, that was /usr/local/Cellar/php54/5.4.26/bin/phpunit.

UPDATE:

I just discovered that pear now installs PHPUnit as a phar named phpunit. It previously installed the PHPUnit source, which was really nice for reference and code completion in PHPStorm. I think that this is the reason things aren't working any longer with PHPStorm, because it's expecting a php executable and not a php archive.

So, I'm moving away from using pear to install PHPUnit, and I'm using composer instead. This bundles PHPUnit directly as a dependency of my project, which makes it more portable than a system dependency. You'll need to add vendor/phpunit/phpunit as a PHP include path in your PHPStorm preferences. This will serve two purposes:

  1. PHPStorm can find the phpunit executable now
  2. PHPStorm will index all the PHPUnit classes now, so you'll get auto-complete. Yay!

To do this, go to Languages and Frameworks in the PhpStorm settings. If you click on PHP, on the right you have your include paths

  • 57
Reply Report
      • 2
    • When using Laravel Homestead, remeber not to use local interpreter, but remote one. For the first time you must add it in Languages & Frameworks -> PHP -> PHPUnit using green plus in upper left corner

I had this problem after adding PHPUnit via composer.

I fixed this by choosing use custom autoloader in Settings -> Languages and Frameworks -> PHP -> PHPUnit, then adding /vendor/autoload.php as the location of the custom autoloader.

  • 24
Reply Report
      • 1
    • Doesn't appear to be a relative path unfortunately. Don't know why I would have to correct this each time I work on a project.

This is the way to do it without using composer, and using your global phpunit.

  1. Phpunit now comes with a phar file. My path was /usr/local/Cellar/phpunit/5.0.0/libexec/phpunit-5.0.0.phar

enter image description here

  1. PhpStorm Preferences -> Path to phpunit.phar -> select the phpunit phar

enter image description here

  1. That's all, good stuff.
  • 4
Reply Report
    • To get autocompletion, the directory containing the phar can be added as an include path. In the image above it would be /usr/local/Cellar/phpunit/5.0.0/libexec/.

I had this same problem for PHPStorm 2017 using Vagrant. First go to Settings -> Languages and Frameworks -> PHP and Add a remote interpreter, then go to Settings -> Languages and Frameworks -> PHP -> PHPUnit click the + on top and click by Remote Interpreter. If you're using Composer autoloader, then enter your full Vagrant path to your autoloader file.

  • 2
Reply Report
      • 1
    • I exactly needs this, but cannot make it work. If I run the test I still get "Cannot find PHPUnit in include path". I did what you wrote - so can you plz give some more detailed information on that?

For future readers, to fix the same issue when using PHPStorm + Vagrant + PHPUnit by defining path to the global phpunit.phar (not composer)

While the tests runned successfully, I was missing the code completion. I had confirmed that phpunit was in the PATH on my local machine, and to make sure, I had added /usr/local/bin to the PHP Include paths in PHP Settings. Still no code completion.

The reason: PHPstorm was looking for phpunit.phar, not just phpunit. To fix, on my local machine I established a symlink phpunit.phar pointing to phpunit:

$ cd /usr/local/bin/
$ sudo ln -s phpunit phpunit.phar

Then I reindexed the project, and code completion started working.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags

Related Questions