• 7
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

My code was working all fine yesterday and today it suddenly just don't want to connect to my database. I have changed no settings on it or on the code and I haven't updated any software either. All I do is this:

new PDO('mysql:host=localhost;port=3306;dbname=test', 'username', 'password');

And I get a nice exception message saying this:

Warning: PDO::__construct(): [2002] No such file or directory (trying to connect via unix:///tmp/mysql.sock) in ...

The thing is: I'm clearly not trying to connect using a unix socket but using TCP/IP. What am I doing wrong? Is there something I'm missing here?

Thanks for any help.

You are using a Unix socket. When reading "localhost" MySQL client libraries don't interpret it as TCP host "localhost" and resolve that name but use the default Socket location. For using TCP on the local machine you have to use 127.0.0.1 as hostname.

To specify the past use unix_socketinstead of host in the DSN. The location of the socket used for localhost can be defined at compile time or in some versions of PHP using pdo_mysql.default_socket in the php.ini.

  • 89
Reply Report
    • But isn't there a way to disable this? I mean, it was working exactly as-is yesterday. And how can I enable the socket on the server so that it works?
      • 2
    • I had PHP scripts working with 'localhost' in the config file, and after a RAM upgrade & reboot, they stopped working when triggered from the console -- still worked in the browser. Changing 'localhost' to '127.0.0.1' fixed it.
      • 1
    • This is annoying af, had this problem over the years under different guises and I always forget about this nitpick and spend some considerable time searching for a solution. That "design desicion" to use a socket if host == 'localhost' seems to be absolute garbage to me.

From the PHP documentation about connection to MySQL using PDO: PDO_MYSQL DNS

The note at the very end says:

Unix only:

When the host name is set to "localhost", then the connection to the server is made thru a domain socket. If PDO_MYSQL is compiled against libmysql then the location of the socket file is at libmysql's compiled in location. If PDO_MYSQL is compiled against mysqlnd a default socket can be set thru the pdo_mysql.default_socket setting.

So in order to fix this you would have to properly configure in php.ini the location of your mysql.sock

  1. Find your mysql.sock file. Common locations:

    • /tmp/mysql.sock
    • /tmp/mysql/mysql.sock
    • /var/mysql/mysql.sock
    • or if you use MAMP or LAMP look for inside the tmp folder for mysql
  2. Edit your php.ini file and properly set the value for pdo_mysql.default_socket

  3. Restart your Apache server to pickup the changes in the php.ini file

  • 9
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags

Related Questions