So i'm new to android studio and trying to create my own app. But Ive been having trouble running the app on the emulator, where the emulator launches but the app does not and I am stuck at Waiting for target device to come online.

I have the most up to date android studio and have Android Emulator 28.0.2. I have the configuration set to launch with the main activity. I have also tried changing the emulator API level and does not change the situation.

Does anyone know how I would go about fixing this? Also do not have an android phone as an alternative way of testing.

Thanks for the help.

Answer

It means that the emulator is not starting. Try deleting it and creating a new emulator the try again. Alternatively, go ahead and run the emulator from the AVD manager then run the project itself.

  • 0
Reply Report
      • 2
    • I've tried many different emulators, and none seem to change anything. I had a friend run it on his samsung phone and it came up in his apps and worked. Although it does not launch and does not show up in the apps on the emulator.

I had the same problem recently. I was using Android SDK Platform-Tools 29.0.5, and Android Studio gave me a warning, suggesting that I should update it. So I updated it to the latest version (29.0.6), and then the problem was fixed. Perhaps it's just a issue of Android SDK Platform-Tools. Hope that helps.

  • 0
Reply Report

Whenever the emulator struggles to come online, a cold boot often solves the problem regardless of the cause. Tools -> AVD Manager -> Your emulator -> Cold boot from drop down menu on the right

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags

Related Questions