• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I'm trying to run my mobile app in the Android Emulator from Android Studio. When I run the app, it prompts me to select the emulator instance:

enter image description here

When I select an emulator instance the build of the application starts and the emulator selected boots up.

enter image description here

After the build completes, Android Studio tells me that its "waiting for the target device to come online" so that it can authenticate with the bridge.

After waiting for some time, I do not get an "Allow USB Debugging" confirmation with an RSA thumbprint so I enable developer mode and go into the settings.

I then try and turn the setting "USB Debugging" off and then back on, I then restart the ADB service on my computer which results in the ADB service asking me to authorise the device (which I cant get the confirmation for)

enter image description here

I have tried this with a few other Android versions, which of only one has worked (API 27) (This version showed me the allow confirmation window as soon as the OS booted) I also checked to see if developer options were enabled on the working OS (API 27), they were not which indicates that the OS images are pre-configured as they are emulators and I shouldn't need to touch any of the settings.

This feels like its an image problem as one of the images (API 27) does work. Does anyone know why I cannot get the other API versions to give me a prompt to authenticate with the remote target?

One thing to note: On the versions that do not work, I cannot see a USB port on the device under Developer Options -> Select USB configuration but on the one working image I can see the USB port is detected and is set to "Charging".

API 27 (The image that works):

API 27 (The image that works)

API 25 (An image that does not work):

enter image description here

enter image description here

This is the prompt I expect to see so that the ADB service can communicate with the device:

enter image description here

I was also facing same problem, but solved by wiping data and killing and restarting the adb server, but it also not worked for again* So , I used

Emulaor with no Play support

select no play store emulator

it only solved mine. Hope it will be helpful to anybody else

  • 1
Reply Report