• 7
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I have a problem in an app updated in play store.

Around 800 user could updated it without problem, but we have 3 users who get this message:

enter image description here

I've try install it with apk instead play store, with a similar result: enter image description here

The min SDK is 16 and the SDK target is 28, and this devices have SDK 27 and 28.

One of these users had a device in which she couldn't install it. But last week buy new device, and she can't install it too. This new device has never had the application installed before.

How can I see any information about the problem?

I had such a problem, when tried to install a new version of my app. I found the reason for the problem when installing the new release version of my app using Android Studio. The error message has explained in detail what the problem is.

So if someone has such a problem I would suggest getting a device on which the error can be reproduced, then trying to install it using Android Studio and check the message.

The full story in my case was as the following: I had two different applicationId for "release" and "debug" configurations. In the new version of the app, I added a "provider" to the manifest. During my development I installed the debug version and then I deployed the new version to the Play Store. When I tried to install the deployed app on this device I got the message that it cannot be installed. The reason was that the release version had the same provider as the debug version, so they cannot be installed both. The solution is to change the authorities of the provider according to the applicationId.

  • 1
Reply Report
      • 2
    • This was the exact issue I was having and I don't know how many more hours/days I would have spent bashing my head against a wall had you not posted this. Thanks a lot !

When errors like this occured, it is recommended to read the link (see common ways to fix the problem). Most of the time cleaning Google Play Services cache and data will do the trick:

Clear the Google Play Store cache

1.Open the Settings menu on your device.

2.Go to Apps or Application Manager. (This option might differ depending on your device.)

3.Scroll to All apps and then scroll down to the Google Play Store app.

4.Open the app details and tap the Force stop button.

5.Tap the Clear cache button.

Repeat the steps above, but replace Google Play Store in step 3 with Google Play services. Try to download the app again.

Clear the Google Play Store data If cleaning the cache of the Google Play Store and Google Play Services doesn't resolve the issue, try clearing the Google Play Store data:

1.Open the Settings menu on your device.

2.Go to Apps or Application Manager. (This option might differ depending on your device.)

3.Scroll to All apps and then scroll down to the Google Play Store app.

4.Open the app details and tap the Force stop button.

5.Tap the Clear data button.

6.Clear data button

  • 0
Reply Report

This looks like a problem on the device, rather than a problem downloading from Google Play store. Logs from this should be in the users device logs, like you get for your app. You can ask your user for the logs, by asking them to send you a bug report. There are instructions here on taking bug reports.

When you look at the bug report, error messages from the Play store are tagged with "Finsky". You may also see errors from the device package manager.

  • 0
Reply Report