• 6
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I accidentally ran my Android Studio project on an emulator (for a different device) instead of my real device (forgotten I unplugged it), and the whole computer froze/ran out of memory. No big deal I thought, I turned off my computer and started it again.

However, now when I start Android Studio, I run into problems. It first says indexing for a very long time (like 10 minutes+), then it goes to Building symbols also for 10 minutes+, until it warns me about low memory and eventually runs out of memory.

The out-of-memory error window gave me the opportunity to increase the memory limit and I tried increase the memory field to 2000 (from 1200 something), and that is where I am now, still building symbols 20 minutes later. Edit: Now it ran out of memory again.

Note that before, when I start Android Studio, everything was set up within minutes

What should I do? Do I have to reinstall Android Studio? Should I change these memory settings to something else, or clean up Android Studio settings somehow?

What finally worked for me was downloading version 3.2 of Android Studio (if I download via Ubuntu Software it is version 3.3), installing to a different directory and reinstalling the sdk to a different directory. Not sure what part of that was the solution, but anyway, if anyway has the same problem they can try this.

  • 1
Reply Report

Try going to C:\users\.android\avd and remove all folders. If the issue is related to your emulators, deleting all folders might help.

  • 0
Reply Report
    • Since I now managed to make it work, I can not check whether or not this would also solve the problem, and I am not going to touch anything on my android installation right now.