• 7
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I've setup client certificate validation in apache and it's working just fine. However I'd like to disable the client certificate validation on specific page.

Here's the config I use so far :

# Verify client certificates
SSLCACertificateFile /etc/my-webserver/ssl/CA.pem
SSLVerifyClient require
SSLVerifyDepth  1

<Location "/public">
    SSLVerifyClient none
</Location>

The problem is that when trying to access /public I still get prompted for a certificate.

The official documentation gives an example on how to do the opposite (i.e. Only enable certificate validation on a specific page).

I was unable to find anything to anwer my problem.

Trending Tags