• 14
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Apache2 mod_ssl checks [duplicate]

This is a canonical question about redirecting from http to https in Apache

Related:

I have an Appache web server which serves both http://example.com/ and https://example.com/. I want to redirect all http requests to https. Currently I'm using this .htaccess rule to redirect http requests to https.

RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} 

It's working as expected for example.com but the same rule is not working for sub links, when I access existing links, like example.com/about it will still load in http, no redirection happens for existing links.

How can I make Apache redirect all http requests to https?

You should configure Apache Virtualhosts to do the job. RewriteMod isn't the appropriate solution for this case and .htaccess isn't either.

In your httpd.conf or equivalent use the following lines accordingly your needs. Edit it to your domain and site.

<VirtualHost *:80>
   ServerName www.example.com example.com
   Redirect permanent / https://example.com/
</VirtualHost>

<VirtualHost _default_:443>
   ServerName example.com
   DocumentRoot /usr/local/www/apache2/htdocs
   SSLEngine On

   ** Additional configurations here **

</VirtualHost>

Hope this clarifies the procedure.

  • 10
Reply Report

On shared hosting, when you don't have better options, you could modify your rewrite rule in the .htaccess:

RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

First, the RegEx at the beginning matches to all requests, including everything behind the domain.

Then, a HTTP Result code of 301 (moved permanently) is thrown back to the client together with the new URL. Most of the modern browsers remember the new URL, in this case the httpS, and redirect to the new url automatically the next time the user calls up the website.

I hope this helps, kind regards

  • 1
Reply Report
    • @Augustin "...with wordpress" - If you are using WordPress then the HTTP to HTTPS redirect would need to go at the top of the .htaccess file, before the existing WordPress directives. The behaviour you have described in the question is consistent with having put the directives in the wrong place (ie. after the WordPress front-controller).
      • 1
    • "you could modify your rewrite rule in the .htaccess" - In terms of actually getting the redirect to function, the only significant take-away from this (over the directive in the question) is the L flag (which is not specifically addressed). The L flag is required in order to prevent the request being further rewritten (by the WP front-controller that presumably follows) which would otherwise mangle the redirect.
      • 1
    • If http and https share the same directory, probably he will also need the mentioned RewriteCond %{HTTPS} off, otherwise it will loop forever :)
      • 1
    • I tried above step, but it still not working for existing links like domain.com/about etc, but adding Redirect permanent / example.com in http.conf working in another server.

Trending Tags