• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Windows 2003 R2 Server not updating wildcard certificate

I can't seem to find the answer for this through google, so hopefully someone here can help me out.

I have a wildcard certificate that is about to expire in 9 days. I received a new certificate from the CA that will expire in 2012. I installed the certificate in the personal certificate store. So I now have both certificates in there.

I created a new test website with the same ip address as the other sites, but gave it a different host header. I applied the new 2012 certificate to this site. So far so good.

If I go to the site in IE, click the lock icon, click on view certificate, it shows the 2010 certificate.

If I delete the 2010 certificate, the site stops working, even though the server still shows that the site has the 2012 certificate installed.

I have been working on this for days and can't seem to figure this out.

Has anybody else had this problem before? Any ideas on how to fix this?

      • 2
    • Is this IIS6 or 7 and what Server OS is this? It could be as simple as opening the properties of your website and importing the new certificate file.
    • Unless you have any errors from the logs to post, maybe a good start is to detail the process you used to install the new certificate? Hopefully there's just an 'i' not dotted somehwere...
      • 1
    • Unfortunately, I don't have the ability to post the log. I'm not sure how I can get anymore detailed than I have already posted. After creating the new site, I went to properties, Directory Security, Server Certificate and went through the wizard. I think the main issue I'm having which I forgot to mention in my post is I'm going from a 1024bit cert to a 2048bit cert.
    • I'm running about 140 websites on this server, so I can't shut it down. They all use the same wildcard cert. I was hoping that if I removed the old cert, the sites would automatically pick up the new cert since it has the same friendly name, but that didn't happen

Because you can only have one certificate per IP addresses, you will need to set up SSL host headers for all the other sites that need the certificate.

  • 1
Reply Report
      • 2
    • here's something interesting...if i remove ssl completely from the site, I can still view the site using https and it still shows the old certificate in the browser...this makes me believe that whoever set this up before, somehow was able to make this ssl cert some kind of default

We fixed it. We had to completely remove the old cert from the server and remove all the bindings from the ip address. Then apply the new cert to each site and reapply the bindings. It was an all day effort.

  • 0
Reply Report

Trending Tags