• 10
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Enable SSL for “Sub-Application” in IIS 8

I have a website in IIS 8 that has several applications nested under it. So:

example.com
    |
    ---app1
    |
    ---app2

example.com has both an http binding on port 80 and an SSL binding on port 443. Both work. However, the app1 and app2 are only accessible via the HTTP binding. I get a 404 when I try to access https://example.com/app1 (http works fine). I have "http,https" listed in enabled protocols.

Any ideas?

      • 1
    • The bindings for example.com are: http bound to all IP addresses on port 80 and https bound to all IP addresses on port 443. As far as I can tell there are no bindings for app1 and app2.
      • 2
    • Right, but with no difference in the bindings, the requests should be getting to the right place.. so it seems like the application code is handling the http and https requests differently. The other potential wrench is, is there a web.config in the root or app directories?

Different behavior for HTTP vs HTTPS between different locations under the same IIS site could be caused by a couple of different issues:

  1. A web.config option that's altering the handling of the request (which was the case for this question)
  2. Application logic which is making content decisions based on the port or protocol that the request came in on.
  • 1
Reply Report

Trending Tags