• 4
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I am trying to debug an app with Intellij 13.0 on Windows 7. Whenever I start debugging I get the following warning:

Warning: debug info can be unavailable. Please close other application using ADB: Monitor, DDMS, Eclipse"

I have tested it on a device and in the emulator. The only thing I have open is Intellij. I tried also with closing adb before I start debugging, but nothing changed.

best regards

[EDIT] I solved it, by updating my android SDK build tools to 18.1.1.

      • 1
    • Can you run monitor from the Android SDK tools, connect to your device and observe the running applications? If it doesn't work, try reinstalling the SDK.

Turn the USB Debugging on Device in Developer Options to off. And then switch it back on. This solved the issue in my case.

UPDATE

One more thing which fixed my case was clearing all existing breakpoints. And then trying to debug again.

  • 13
Reply Report

First make sure you close any application use ADB , DDMS

like if you open Eclipse with android studio

Second restart your ADB from terminal

adb kill-server
adb start-server

if you cannt find terminal use this image to guide you

enter image description here

if this doesn't work with you close android studio and open it again

the cause of error , many application share ADB this why you cant start debugging

  • 5
Reply Report

Had similar problem in Android Studio (0.5.1) with SDK 18.0.1

Warning: debug info can be unavailable. Please close other application using ADB: Monitor, DDMS, Eclipse

As you suggested updating the SDK worked. Now running on 19.0 and the problem got resolved.

  • 3
Reply Report

The same issues occured with me all of a sudden while debuging an app on my samsung galaxy S6

This is what worked for me : closed android studio killed adb , using adb kill-server removed all of my previous breakpoints(debug points) Restarted android studio and my phone Restaterted Mac did a debug without any breakpoint. Then again did debug by putting the breakpoints again in my code, Eureka it worked. Luckily it burned only half hour of mine.

  • 2
Reply Report

A pretty straight forward solution is running the following commands in the command Terminal of Android Studio :

adb kill-server
adb start-server

and then try debugging again. It should be working now.

  • 2
Reply Report

You can restart ADB in windows without writing any commands.

Just open Task Manager

Sort the list by name

Find process named "adb" enter image description here Right click on it and then select "End Task" Done

Next time you run any app the adb will start with a new instance.

  • 1
Reply Report

This is a problem of ADB connections as sometimes ADB cache a dead connection on your real/virtual device and due to which the port is busy and u cannot connect to it.

The simplest solution to this is RESTART your ANDROID phone that's it.

  • 1
Reply Report

This happened to me and the thing I did was to set

android:debuggable="true"

in <application> tag...like:

    <application android:allowBackup="true"
             android:label="@string/app_name"
             android:screenOrientation="portrait"
             android:largeHeap="true"
             android:icon="@drawable/icon"
             android:debuggable="true"
>

This fixed the problem with later SDKs.

  • 0
Reply Report