• 13
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I have this situation:

postix/sasl/dovecot

I recently added dovecot and sasl and i can only receive email to postfix if i use this email format: user@serverhostname.domain.com

If i use desired format: user@domain.com there is bounce back to originator email address 5.0.0 smtp; 554 5.7.1: Relay access denied

my MX is pointing to domain name

I have only one domain.

postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_at_myorigin = yes
append_dot_mydomain = yes
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_command =
mailbox_size_limit = 0
masquerade_domains = $mydomain
mydestination = $myhostname,$mydomain,localhost
mydomain = domain.cz
myhostname = host.domena.cz
mynetworks = 192.168.1.0/28 127.0.0.0/8
myorigin = /etc/mailname >> is hostname.domain.cz
readme_directory = no
recipient_delimiter = +
relay_domains = $mydestination
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,permit_auth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_tls_ask_ccert = yes
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/certs/cacert.pem
smtpd_tls_key_file = /etc/ssl/private/privkey.pem
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

Can someone suggest solution?

Forgot to mention, difficult part is that there is no record in log. /var/log/mail.log and /var/log/mail.err are empty. Interesting part is that I can receive email just fine over www.dnsexit.com, but other 3 mail clients including web mail servers does not go trh

      • 1
    • Forgot to mention, difficult part is that there is no record in log. /var/log/mail.log and /var/log/mail.err are empty. Interesting part is that I can receive email just fine over www.dnsexit.com, but other 3 mail clients including web mail servers does not go trhu
    • try setting myorigin = $mydomain as format appears to be user@myorigin.mydomain I've not tried this but since you are masquerading.. I've nothing more on this.

Trending Tags