15Answers
  • 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Java/Eclipse - No more R file ever

I'm on Eclipse for hours now and I didn't found a solution yet for my problem even after many searches on internet: I have no more R.java file on my projects.

On just created or on my old projects, i don't have R file anymore and I tried so many solutions (uninstall, re-install Eclipse, clean my project, check all my XMLs, fix problem with android tool and so on ...)

Please someone can tell me what to do in this case?

Hey If you just updated to ADT Rev 22 :

I had the problem too. There is a new component in the Tools folder called "Android SDK Build-tools" that needs to be installed.

Step 1

Open the Android SDK Manager

Step 2

Select the newly added Build Tools and install. (If problem stays then go to Project Properties => Java Build Path => Order and Export and check Android Private Libraries, then clean and build project.

It may be necessary to repeat the process, restart the SDK Manager after the update and make sure it looks like this (all tools installed):

See the Build Tools in the image

More info:https://groups.google.com/forum/?fromgroups=#!topic/android-developers/rCaeT3qckoE%5B1-25-false%5D

  • 111
Reply Report
    • Solved for me. I was trying to build a project that was working on another machine without any issues, but doesn't made gen folder with mine actual installation. Installed the Build-tools package and worked right after that.
      • 1
    • My Eclipse tricked me, i installed Bild-Tools but i decided to check again after its install and i had to install again the same package again but IT WORKS !!!!! Thank you guys for your advices

Perhaps in Project Properties -> Java Build Path -> Libraries you don't have:

  • Android 4.2.2 (or other version)
  • Android Dependencies ?

If so, then right click project - > Android tools -> fix android properties and see if this library showed up.

  • 1
Reply Report

Thank you all for saving me! I've spent the whole afternoon on search this error. Finally, my project works. By the way, I also encountered one problem which i wanna share with you:

After upgrading, even if my project has not errors anymore. During runtime, it seems it couldn't find the classes from the jars placed in \libs.

Go into Project=>properties => Java build path= > Order and Export. Please make sure all your jars are checked.

  • 1
Reply Report

If this problem occurs suddenly in a well working project,

the first step is to find whether the problem occurs only in the current project or in all other projects.

if all other projects in the current workspace are working then 90% problem is with XML / mainfestfile/resourse file that you edited recently.

This error is not shown as red mark we have to find out what we have done recently in these files.

  • 1
Reply Report

Close your eclipse and after refreshing system, try to open Eclipse again. I think you are using Emulator along with the eclipse. It may be because of the low Memory problem (RAM) of your system. I used to face the same problem when I use Emulator

  • 0
Reply Report

whenever there is any mistakes in any of the xmls the R goes missing when a build or clean happens so check for any xml errors in your project unless you fix it you cant get back your R on clean or build. fix the xml files and perform a clean you will have the R generated. Also check in File->properties->Builders and see if everything is checked

  • 0
Reply Report

Reinstall everything and it'll work.. i.e. go back to Google SDK or w.e. you're using and download it. Update it to latest in SDK Manager. Go into Eclipse-Project-Prefs-Java build path-order/export TICK EVERYTHING.

  • 0
Reply Report

problem: No R file get generated.

guess: Try cleaning project if it is old one. Else create new project with no R get generated and with no compile errors but this: no project.apk

In this case you have to check your SDK for the built-tools. May not be installed after updating SDK.

Thus download them if not download here, then put them under directory: SDK/built-tools folder. Lastly, and most important, is to Run the SDK As Administrator. This guarantees refreshing SDK with all packages appearing in it.

Install the SDK-Built-Tools or any missing packages according to the above link and you're done.

hope this helps.

  • 0
Reply Report

In my case there is error due to "&" inside strings.xml file(but error not shown) for declaring string for a array type. Now the problem has been solved as I changed "&" to "and".

So, please make sure that you do not have such silly use of symbols, and clean the project.

  • 0
Reply Report

I have had the same kind of problem, however Rechecking all XML files in the Resources folder was helpful in my case. I found syntax error in my XML files. Cleaning and building the project again can be helpful sometimes too.

  • 0
Reply Report

I had the dreaded not more R.java.

Some of the things I've used in the past:

  • Clean / rebuild (the first thing we all try)
  • Restart eclipse (optionally reboot pc/mac)
  • Update both SDK/ADT eclipse plugin to latest version
  • Create new eclipse workspace and import project
  • Enable Verbose AAPT build output Eclipse menu>Preferences>Android>Build
  • Port project to Android Studio / Gradle (this helped my actually see the AAPT error i was getting Error Code:138)
  • Delete recent XML changes - Ultimately I found deleting recent menu.xml files I'd added and commenting out where they were referenced fixed the issue and I finally got R.java.
  • 0
Reply Report

I got the error recently and had found no fault in any layout or value file. After a lot of tries I add another Activity and the R.java was build and the error disappeared. I don't know why this occur, but it takes me hours.

  • 0
Reply Report