• 13
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

Scrollable views such as the ListView have a fade out of the content along the edges where there is more content in that direction. How can I turn this fading off? I know you can change the cacheColorHint as discussed here: http://developer.android.com/resources/articles/listview-backgrounds.html but that is not what I am looking for and will not achieve what I am looking for in this case.

I want to disable the fade completely or be able to reduce the size and or transparency of it. Is this possible?

I can't actually test it right now, but I believe fadingEdge is what you're looking for:

android:fadingEdge="none"

or

listView.setVerticalFadingEdgeEnabled(false);

http://developer.android.com/reference/android/view/View.html#setVerticalFadingEdgeEnabled(boolean)

  • 85
Reply Report
    • That did it! Thank you. Also, I see there is a field called android:fadingEdgeLength for controlling the length of the fade. Thanks again.
    • Heh, funny that this answer comes back to help ME. Thanks @Warpzit, I was actually wondering yesterday why my fading edge wasn't working on ICS. :)
      • 1
    • @kcoppock heh well I figured it out because I was wondering why fadingedge was deprecated :) Glad it already helped someone :D

In case someone finds this via Google:

As mentioned, android:fadingEdge is deprecated. Use this instead:

android:overScrollMode="never"
  • 46
Reply Report