• 6
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Failed to import new Gradle project in android studio

I got the error when i create a new Project using android studio. below i attached a screenshots of error message..enter image description here I am using windows 7 (64 bit) Please help me.

I also had an issue downloading gradle through AndroidStudio. I tried the following.

  1. Go to your AndroidStudio directory where you installed your studio Like D:\User\AndroidStudio
  2. In AndroidStudio go to \AndroidStudio\plugins\gradle\lib and copy gradle.jar
  3. Paste gradle.jar file in \AndroidStudio\lib directory.
  4. Download gradle directly from Gradle
  5. Copy the contents of gradle-1.6-bin.zip - After extracting zip file - (bin, media, init.d, lib folders) to \AndroidStudio\plugins\gradle
  6. Restart AndroidStudio

* Updated Answer *

And after following all the steps listed above, if it is not working, Kindly check below things.

1) Please delete .gradle folder from your user like C:\Document and Settings\AndroidUser\***\.gradle

2) You can check your HTTP Proxy in Settings.

Hope this helps!

  • 32
Reply Report
    • after completion of step provided by you, i create new project and it throws an error "org.jetbrains.plugins.gradle.settings.GradleSettings cannot be cast to org.jetbrains.plugins.gradle.settings.GradleSettings"
      • 1
    • @Hardik Nadiyapara, I had the same problem as you after following these instructions. After deleting gradle.jar from AndroidStudiolib (the one you pasted in step 3) it works.
      • 1
    • @HardikNadiyapara As AndroidStudio is in early preview access version, you can do two things 1) Please delete .gradle folder from your user like C:Document and SettingsAndroidUser***.gradle or 2) You can check your HTTP Proxy Settings.
      • 2
    • @SiKni8 Hi, Google recently released newer version of Android Studio with some bug fixes. You can download that one. Thanks.

In my case, it was sufficient to specify the location of the Gradle distribution included with Android Studio when requested.

On a mac, it was: /Applications/Android Studio.app/Contents/gradle/gradle-2.2.1
On Linux, it can be generalized to {android-studio-root}/grade/gradle-{version}

  • 28
Reply Report

If Android Studio offers you to choose home folder for gradle, just choose "Use customizable gradle". Then, if you see only gradle files, but no classes and resources - click on "Synchronize gradle" and it will be alrigth. Hope this helps

  • 2
Reply Report

For me, this issue only occurs when using a proxy server. If you specify a proxy server in the settings, everything is working fine for me. You can specify a proxy server by File->Settings->HTTP Proxy

  • 1
Reply Report

If you using ubuntu behind a proxy, in my case I'm using ctlm, you must change the jetbrains' proxy setting in /Home/UserName/.AndroidStudioPreview/config/options/other.xml

<option name="USE_HTTP_PROXY" value="true" />
<option name="PROXY_HOST" value="localhost" />
<option name="PROXY_PORT" value="8080" />

This is my configuration I don't need autentificated user.

bests Regards

  • 1
Reply Report

Had the same problem I think because our internet set-up blocked access to https://dl-ssl.google.com site.I resolved in by downloading gradle 1.6 zip then extracted it in some folder.go to File --> Settings --> click option-->Gradle ,the check use local gradle distribution and point it to the extracted directory eg C:\android-studio\plugins\gradle\gradle-1.6-bin\gradle-1.6 Then it was okay

  • 1
Reply Report

We have to change the android sdk source in the project settings to our sdk where we have installed the android build tools.

I had the same issue and by doing this, it worked. Thanks.

  • 0
Reply Report

Check your proxy setting for gradle. If it still fails after set the HTTP Proxy in setting menu, you may add gradle.properties as following.

First, go to the project directory. (By default-for Windows-, projects will be created to {user}\AndroidStudioProjects\{ProjectName}). And then create gradle.properties file as below.

systemProp.http.proxyHost=www.somehost.org
systemProp.http.proxyPort=8080
systemProp.http.proxyUser=userid
systemProp.http.proxyPassword=password
systemProp.http.nonProxyHosts=*.nonproxyrepos.com|localhost

you can also refer to the User's guide.

  • 0
Reply Report
      • 2
    • I have gradle-wrapper.jar and gradle-wrapper.properties under the wrapper folder. Still not working.