• 9
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

SDL init failure, reason is: No available video device

I tried to start my avd on Ubuntu 64bit 10.10, but it failed and shows the following in the log:

SDL init failure, reason is: No available video device

What can I do with that?

I tried to search for solutions and someone says it needs x11/sdl/jdk library and I installed them all but it still does not work.

For Fedora 14 and 16 64bit.

Install these packages:

yum install glibc.i686 ncurses-libs.i686 libstdc libstdc++.i686 \
    libzip.i686 libX11.i686 libXrandr.i686 SDL.i686
  • 33
Reply Report
      • 1
    • +1 Awesome man. I tried running the emulator after the installation of each of the packages missing on my machine. After the install of libXrandr.i686, it worked!

I just encountered this problem on Ubuntu 12.04 64-bit (Precise) and solved it by installing the 32-bit version of libsdl:

sudo apt-get install libsdl1.2debian:i386
  • 21
Reply Report

Try unsetting any environment variables along the line of SDL_*, such as SDL_VIDEODRIVER. If that doesn't work, try export DISPLAY=:0.

  • 8
Reply Report
    • FWIW, seems like most of the other answers relate to the "first time usage" of an SDL binary; export DISPLAY=:0 worked for me and may be relevant to others where a SSH init script changes the chosen display for X11 forwarding.

I get the "SDL init failure" when running the "emulator" command with a user with not enough privileges. Ex. jenkins user gets the error, but not root.

Drop to the commandline and run the emulator command with your normal user. You should get the same error.

Then switch to root and run emulator command again to see if user permissions or missing/wrong user environment variables is the cause of your problem.

  • 2
Reply Report

https://fedoraproject.org/wiki/User:Hpejakle/Android

Couple of things: Run your emulator call with strace, that'll tell you where it's going sideways... May not necessarily allow you to fix it easily though...

It could be a number of things, the fact that your on 64 bit ubuntu tells me that there are probably missing libraries (32bit).

Check out the link and see if anyone has come up with a faq for Ubuntu 64

Good luck,

Gary

  • 1
Reply Report