2Answers
  • 6
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

High CPU Load on Synology by smbd

I have a Synology DS213j which I access through a VPN via the build-in VPN Server (I use OpenVPN) using Windows Explorer.

Copying files to my local hard drive is very slow in the range of only ~170 KB/s. This seems to be limited by the Synologys CPU which is at 100%. Looking at the ressource monitor in DSM, it shows the smbd process takes >90% of CPU.

The NAS runs DSM version 5.2-5592. The Specs say it has a 1.2 GHz CPU. Shouldn't this be capable of more than this?

I read the DSM 5.2 versions have this kind of issue where they are to heavy-weight for older NASes. Is version 6 better performancewise? Should I downgrade to 4? Or is this not an issue in the OS, and can be solved otherwise? How?

First, this seems a common problem with DS213j and DSM 5.1+. Someone reported that after a reboot, the problem went away: have you tried it?

From your top data, it seems that the CPU is busy with system time, ie: doing some syscall. Try changing the following parameters in the smb.conf file and then restart the NAS:

  • change notify = no
  • kernel change notify = no
  • server max protocol = NT1
  • client max protocol = NT1

Does they change anything?

  • 5
Reply Report
      • 1
    • Adding your changes and restarting the service using synoservicectl, the high cpu load has gone away but performance has not improved. Still about 170 KB/s. Most cpu is now taken by openvpn (~5%).
      • 2
    • How much bandwidth did you have? 170 KB/s are about 1.5 MB/s of upload bandwidth which, based on your WAN tech, can be quite good.
      • 1
    • The router says 1.9 Mbit/s upload bandwidth. This should translate to 237.5 KByte/s. So far, I'm getting ~70% netto performance out of it. I feel like this is probably the bottleneck. Also, I feel quite stupid now. Thanks for your help!

I had also the same problem with :

  • random slow load problem when I navigate into folder with Windows Explorer
  • hight CPU usage by the smbd process (~50%) when the random problem that talk about before append
  • poor speed performance when I transfert file between my Windows computer and my Nas (< 25 MB/s with gigabite connection...)

I solved these 3 problems by simply switching SMB2 to SMB 3 in:

Config Panel > Files services > Win/Mac/NFS panel > Advanced settings in Windows part > Max protocole => Enable SMB 3

I hope these solve your problems too :)

  • 4
Reply Report

Trending Tags