• 10
name Punditsdkoslkdosdkoskdo

TFTP running in boot2docker can't connect

I've asked this question over at the Unix Stack Exchange, but soon realised that the issue was not with docker, but with either VirtualBox or Windows, so I'm asking it here instead.

I'm trying to install a TFTP server in a Docker container running Ubuntu (either 12.04 or latest, it fails on either) via Boot2Docker on Windows 8.1. My goal is to install FOG so I can easily deploy it on a few servers or laptops around my organisation.

When I run my docker image on two Ubuntu laptops, TFTP works great. I can PXE boot, run tftp [IP address here] GET boot.txt on Windows or Linux and all that jazz.

When I run the docker image on Windows 8.1 (I've tried three PCs), TFTP times out, despite port 69 being open in VirtualBox AND the Windows Firewall (which is disabled anyway). If I run tcpdump in the container, plus Wireshark on the Windows 8.1 host AND on the remote Windows 8.1 machine, I can see TFTP packets leaving the remote machine, arriving on the host, arriving on the guest AND leaving the guest, but not leaving the host, nor arriving at the remote machine. The strange thing is, I can access port 80 (FOG's web-based control panel)

iptables, or UFW or any sort of firewall is not installed in my container, so that leads me to believe that either VirtualBox or Windows is the issue, and I don't know which.

My work PC has McAfee installed, but my home PC has no AV installed at all, so it's not that. I'm at a loss here.

Any clues?

I've seen Windows 8 preventing certain net traffic "even" when the native firewall looks off! Please remember TFTP is a protocol that negotiate its transfers on port 69 but later the actual data-transfer is carried out on a randomly selected port. Both ports must be open to traffic. Instead of turning Windows firewall off why don't you try creating the corresponding opening firewall rules.

  • 0
Reply Report
      • 2
    • Yep, I know all too well about the firewall continuing on despite being disabled, so I created two firewall rules for outgoing and incoming that allows all UDP ports, regardless of port number or origin. And even then it still didn't work, so I'm a little more convinced that it's not a firewall issue either :)

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags