google-cloud-platform,apache-mesos"/>
  • 11
name

I have been working on an ansible script for installing a DCOS mesos cluster. I have been following the steps in the advanced installation section of the documentation of DCOS inside my ansible script. I get the following when my ansible script runs

bash dcos_installer.sh master

results

Starting DC/OS Install Process
Running preflight checks
Checking if DC/OS is already installed: PASS (Not installed)
PASS Is SELinux disabled?
Checking if docker is installed and in PATH: PASS 
Checking docker version requirement (>= 1.6): PASS (1.11.2)
Checking if curl is installed and in PATH: PASS 
Checking if bash is installed and in PATH: PASS 
Checking if ping is installed and in PATH: PASS 
Checking if tar is installed and in PATH: PASS 
Checking if xz is installed and in PATH: PASS 
Checking if unzip is installed and in PATH: PASS 
Checking if ipset is installed and in PATH: PASS 
Checking if systemd-notify is installed and in PATH: PASS 
Checking if systemd is installed and in PATH: PASS 
Checking systemd version requirement (>= 200): PASS (219)
Checking if group 'nogroup' exists: PASS 
Checking if port 80 (required by mesos-ui) is in use: PASS 
Checking if port 53 (required by mesos-dns) is in use: PASS 
Checking if port 15055 (required by dcos-history) is in use: PASS 
Checking if port 5050 (required by mesos-master) is in use: PASS 
Checking if port 2181 (required by zookeeper) is in use: PASS 
Checking if port 8080 (required by marathon) is in use: PASS 
Checking if port 3888 (required by zookeeper) is in use: PASS 
Checking if port 8181 (required by exhibitor) is in use: PASS 
Checking if port 8123 (required by mesos-dns) is in use: PASS 
Checking Docker is configured with a production storage driver:  WARNING: Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.th
inpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
 WARNING: Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true
` to suppress this warning.
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
FAIL (devicemapper, /dev/loop0)
Docker is configured to use the devicemapper storage driver with a loopback
device behind it. This is highly recommended against by Docker and the
community at large for production use[0][1]. See the docker documentation on
selecting an alternate storage driver, or use alternate storage than loopback
for the devicemapper driver.

[0] https://docs.docker.com/engine/userguide/storagedriver/device-mapper-driver/
[1] http://www.projectatomic.io/blog/2015/06/notes-on-fedora-centos-and-docker-storage-drivers/

The errors I don't know how to fix are the ones related to the storage driver. I am using Google GCE instances running centos 7, they do not use LVM and hence I can't use the recommended devicemapper(direct-lvm) storage driver.

My question is, is there a way to use the devicemapper driver or do I use another storage driver?

I will open source my script once it works.

update

Overlayfs worked for me

      • 2
    • Were you able to resolve the issue? If so, is it possible to post the answer and accept it so other people can benefit from it
      • 1
    • I found out the overlay fs (which needs kernel; 3.18) storage system is supported by DCOS on docker. Unfortunately the Centos kernel only supports 3.10 :( I'll be looking at Ubuntu and Debian for installing DCOS.
      • 2
    • The overlayfs actually worked. Redhat had backported the relevant code to get overlayfs to work in 3.10

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags