• 7
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

TLDR: see the subject line. Now here's the motivation...

We have some existing clusters that successfully use Heartbeat 3.0.5 together with Pacemaker 1.1.6, on Ubuntu 12.04LTS Precise Pangolin.

$ man heartbeat | tail -1
Heartbeat 3.0.5                                     24 Nov 2009
$ man pacemaker | tail -1
Pacemaker 1.1.6                                      May 2014

They use crm configure to set various properties, and so on.

On our newest cluster, we wanted to "upgrade" to Ubuntu 14.04LTS Trusty Tahr. Unfortunately, Trusty Tahr ships with Pacemaker 1.1.10 by default:

$ man heartbeat | tail -1
Heartbeat 3.0.5                                     24 Nov 2009
$ man pacemaker | tail -1
Pacemaker 1.1.10                                  September 2014

On this version of Pacemaker, running crm configure property simply hangs and then exits (after 30 seconds) with

$ crm configure property stonith-enabled=false
Call cib_apply_diff failed (-62): Timer expired
ERROR: could not patch cib (rc=62)
INFO: offending diff: <diff crm_feature_set="3.0.7">
  <diff-removed>
    <cib epoch="8"/>
  </diff-removed>
  <diff-added>
    <cib crm_feature_set="3.0.7" validate-with="pacemaker-1.2" admin_epoch="1" epoch="9" num_updates="0" cib-last-written="Tue Jan 27 19:49:12 2015" update-origin="[REDACTED]" update-client="cibadmin"/> 
  </diff-added>
</diff>

Also, crm_mon -1 reports Current DC: NONE and all five of our nodes are listed as OFFLINE; I'm not sure if that's related, but I suspect it is.

Looking at dmesg | tail, I can see that the daemon crmd has segfaulted during the running of the crm command.

$ dmesg | tail
[REDACTED 9 OLD LINES]
[77926.020154] crmd[30900]: segfault at e8 ip 00007fdba24b6861 sp 00007fff57748e78 error 4 in libhbclient.so.1.0.0[7fdba24b4000+a000]

This is due to the following known bug in pacemaker-1.1.10: http://notes.retrosnub.co.uk/post/84241160984/heartbeat-pacemaker-in-ubuntu-14-04

Anyway, this implies to me that Pacemaker 1.1.10 is completely unusable with Heartbeat.

We have two choices: move forward to the even less battle-tested Pacemaker 1.1.11, or retreat to the safety of Pacemaker 1.1.6. (Or, of course, abandon Heartbeat altogether, but that seems like an even riskier move.) We would like to cut our losses and retreat.

We could retreat all the way to Ubuntu 12.04LTS, but (for reasons that may boil down to "pride and inertia") we'd rather stick with Ubuntu 14.04.

What is the simplest way to install Pacemaker 1.1.6 on a machine running Ubuntu 14.04 Trusty Tahr? Is there an official (apt-get installable) distribution? If not, how does one do it?

Step-by-step, cut-and-pasteable instructions will be greatly appreciated.

      • 1
    • @c4f4t0r That falls under the aforementioned "abandon Heartbeat altogether, but that seems like an even riskier move." It's also been suggested that we could switch from Heartbeat/Pacemaker to Keepalived, but again we don't want to do that. We just want to get off the buggy Pacemaker 1.1.10 in the safest way possible.

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags