• 4
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Debian sysctl config not persisting on reboot

I am running ubuntu 14.04:

Linux WEBLB3 3.13.0-79-generic #123-Ubuntu SMP Fri Feb 19 14:27:58 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I have modified the /etc/sysctl.conf file to set sysctl settings on reboot, it contains this value:

net.nf_conntrack_max = 2147450880

When running sysctl -p the connection track value is set appropriately. However, when the system reboots and /etc/init/procps.conf runs to set the system control vars from /etc/sysctl.d/* and /etc/sysctl.conf the nf_conntrack_max value does not get set appropriately and falls back to the default of 65535.

When I boot the server it takes ~15 seconds for sysctl -a to produce an output that contains the nf_conntrack_max value, so I am wondering if a race condition exists that is causing the /etc/init/procps.conf script to run and set the values too quickly.

I can write an upstart script that runs sysctl -p after sysctl finishes initializing but that feels like a terrible hack to me.

How can I ensure that all values in /etc/sysctl.conf get set appropriately on reboot?

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags