• 12
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Jetty service fail on start in ubuntu 14

I install the solr-jetty package in a Ubuntu 14 container running in a cloud9 workspace.

To install the package I run the following command:

sudo apt-get install solr-jetty

The installation doesn't return any error. Then I try to start solr with the following command:

sudo service jetty start

But I receive the following error:

 * Starting Jetty servlet engine. jetty
/etc/init.d/jetty: 274: /etc/init.d/jetty: /usr/sbin/rotatelogs: not found
 * Jetty servlet engine started, reachable on http://host-solr-3694477:8983/. jetty
   ...fail!

In the log file of jetty I get the following message:

failed setting default capabilities.
set_caps(CAPS) failed for user 'jetty'
Service exit with a return value of 4

The problem seams to be that jetty user have no permission to invoke the set_caps(CAPS). How can I resolve this issue?

A workaround (but as a solution, this is a terrible idea)

I hit the same problem whilst building solr 4.6 on Ubuntu 12.04 for a container to be used in our development pipeline.

There is anecdotal talk on forums about changing the storage from the default AUFS to btrfs, but this didn't work for me.

In the end (as this is just for dev), I changed the jetty user in the /etc/init.d/jetty script from 'jetty' to 'root' and this worked.

Like I said - not ideal and not recommended for anything but a development system.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags