• 6
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

name Punditsdkoslkdosdkoskdo

Attempts to update gitlab fails with error

Context: We're trying to migrate our gitlab server from one provider to another and upgrade it to the latest release and we're trying to find a way to do it in a way that doesn't break everything.

I have a VPS with a gitlab version 7.0.0 (omnibus) on an ubuntu OS which I'm trying to upgrade to the latest release. Apparently, gitlab didn't have a package repo at the time when 7.0.0 was a thing so I followed this page to try and upgrade via repo. To be safe, I started another VPS instance on the new provider, made a backup through this, copied the deb package from the original server, installed the deb package and did a restore which worked perfectly. Accessing the new VPS by IP works just as well as the original.

Then I finally did the update as per instructions.

What I get instead by the end is this:

Chef Client failed. 9 resources updated in 21 seconds
dpkg: error processing package gitlab-ce (--install):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 gitlab-ce

I tried accessing via IP and lo and behold it broke with an error 500.

I tried digging through the details and I found this:

Error executing action `run` on resource 'bash[migrate gitlab-rails database]'

With my boss' blessing, and to rule out an environment issue, I tried making a snapshot of the gitlab server, started another VPS instance on the original provider and loaded it up with the snapshot, effectively cloning the server. I attempted the update on that and it still breaks. I tried manually downloading the package and installing via dpkg which still doesn't work.

By this point, I'm not sure what I'm overlooking.

After sleeping on it, I had an epiphany: upgrade to version 7.10 first via package server using sudo apt-get install gitlab-ce=7.10.0~omnibus-1. then do: sudo apt-get upgrade. That successfully upgraded it. Wow, the interface looks so different too.

Now, onto my next adventure, backup and restore.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags