• 6
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I followed this guide to install a single machine setup, and it appears to have worked. I get the openstack-status screen and it's green across the board.

openstack-status

Now I want to access the dashboard at 10.0.3.12/horizon from another machine as I only have SSH to the host machine. But it timeout :(

So I googled a bit and tried to setup a bridge but couldn't get that to work so abandoned that approach. Then I read about Associate floating IP addresses which says:

After you associate the IP address and configure security group rules for the instance, the instance is publicly available at the floating IP address.

Sounds pretty good to me! So I fire the nova command and 'nova' is not a known command... what gives?! OpenStack uses nova - I think... Why isn't nova installed then? Am I doing it wrong? Ok I know neutron is installed as the openstack-status says it's checking neutron something and that reports back as a success. So I fire neutron and 'neutron' is not a known command. !"#%@

It seems no matter what I try I end up in a ditch.

I need help! What do I do?

I resolve this problem with iptables forwarding:

iptables -t nat -A PREROUTING -p tcp -i eth0 --dport 80 -j DNAT --to-destination 10.0.3.12:80
iptables -A FORWARD -p tcp -d 10.0.3.12 --dport 80 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT   

(replace eth0 and 10.0.3.12 to yours)

  • 1
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags