• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I am having troubles when trying to update my system after it told me there was some available updates...

I first ran the following command without any problem :

sudo apt-get update

Then I tried to "upgrade" and here is the output :

#:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libserf-dev : Depends: libserf-1-1 (= 1.3.3-1ubuntu0.1) but it is not installed
 libserf1-dbg : Depends: libserf-1-1 (= 1.3.3-1ubuntu0.1) but it is not installed
 libsvn1 : Depends: libserf-1-1 (>= 1.2) but it is not installed
E: Unmet dependencies. Try using -f.

So I ran "sudo apt-get -f install" :

#:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libserf-1-1
The following NEW packages will be installed:
  libserf-1-1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
7 not fully installed or removed.
Need to get 0 B/42.2 kB of archives.
After this operation, 164 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 360153 files and directories currently installed.)
Preparing to unpack .../libserf-1-1_1.3.3-1ubuntu0.1_amd64.deb ...
Unpacking libserf-1-1:amd64 (1.3.3-1ubuntu0.1) ...
dpkg: error processing archive /var/cache/apt/archives/libserf-1-1_1.3.3-1ubuntu0.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libserf-1.so.1.3.0', which is also in package libserf1:amd64 1.3.2-0.1ubuntu0~ppa4
Errors were encountered while processing:
 /var/cache/apt/archives/libserf-1-1_1.3.3-1ubuntu0.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So the "-f install" did not solve my "unmet dependencies" problem...

Does anybody has an idea on how to fix this ?

Any help would be very appreciated !

Thanks a lot !

OK ! I resolved my problem ! I found the answer on AskUbuntu : there.

I had to run the following command : sudo dpkg -r --force-depends libserf1 Then I could run the update without any problem !

  • 1
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags