• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I downloaded it (version 1.6.0), unpacked it in /opt/gitblit (ubuntu server 14.04.1), configured http to 8280 and disabled https assigning 0 (I expose it by https using nginx).

I created gitblit user and added it to 'sudo' group by running: sudo adduser gitblit sudo (gitblit user has a strong password).

I installed it as a service by running: /opt/gitblit/install-service-ubuntu.sh.

I tried to start it by running: sudo service gitblit start. The message Starting gitblit server appears. It's the only message.

When I hit -in the same local machine- http://127.0.0.1:8280, the connection could not be made. When I run sudo netstat -anp | grep 8280, nothing appears.

I see no error messages, but the server is not starting.

Question: What am I missing?

I had the same problem. The reason the service would not start in my case is that the gitblit user did not have permission to access any of the /opt/gitblit files. This is because (doh) I had installed gitblit as root. The solution was simple:

chown -R gitblit:gitblit /opt/gitblit
  • 1
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags