• 4
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I'm following this guide to install a testing instance of OpenStack Kilo with a very basic environment in a VirtualBox machine running Ubuntu server 14.04 x64. I've managed to get to the point where the keystone user (mariadb/mysql) has to populate its database with this command:

# su -s /bin/sh -c "keystone-manage db_sync" keystone

This doesn't give me any output at all and just brings me back to the shell. I've tried different approaches:

  • I don't think it's a network problem. The system is running on a simple virtual machine with a ethernet card. Also just in case, I set up the nodes controller/network/compute pointing to 127.0.0.1 or the local IP, just in case. It didn't work.
  • Not a privileges problem either. I've tried to access mysql both through phpmyadmin and command-line, as root and as keystone. In both cases the keystone database exists and can be manually edited (added tables etc...) but it's completely empty (no tables at all). I've also set as a temporary measure bind-addresses = 0.0.0.0. No change.
  • keystone.log and keystone-manage.log don't show any information related to the problem.

It someone has run into this same problem or can point to some possible step that might be failing, I would appreciate it.

I found the answer just through some testing. The guide asks you to create an hexadecimal token and write it into /etc/keystone/keystone.conf like this:

[DEFAULT]
#
# From keystone
#
admin_token = 481c6cd1422689a5e7e1
verbose = True

Just removing the token (or commenting it) does the trick:

[DEFAULT]
#
# From keystone
#
#admin_token = 481c6cd1422689a5e7e1
verbose = True

Now the database is created and filled:

2015-11-16 16:41:13.662 14706 INFO migrate.versioning.api [-] done
  • 1
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags