google-compute-engine,udp,ipc"/>
  • 5
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I have a small and simple UDP server that's been working in several hosting places for years.

I just created a new vm in the google cloud, a Compute Engine, with linux.

Default settings for a small machine (f1-micro (1 vCPU, 0.6 GB memory) CPU platform Intel Sandy Bridge), with only changes:

  • static public IP
  • inbound firewall rule to allow UDP traffic at the server port (22000)

Everything works great and can be connected from anywhere in the world, except from the machine itself (there's a stats module that asks the server for info - this also work from remote, but not from the machine itself). This worked in all other linux machines I tried the server on.

I was pointed at changing the address the server binds to as a possible solution, and as I have access to the source code I tried all I can imagine to no effect (binding to 127.0.0.1, 0.0.0.0, "localhost", specific IP...).

I have also tried adding a specific inbound and outbound firewall rules.

There are tons of information around about how to fix when you cannot connect from outside - my problem is the opposite, and I'm of ideas.

Ping etc work normally.

Thanks in advance

Solved!

Apparently in these machines / kernel UDP sockets need to have a name (bind) before sending - never needed in other machines I installed the server.

Not a server administration thing - it just seemed as if it could be.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags