• 13

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191


File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

So I installed MongoDB v4.0 on an Ubuntu 18.10 VM running on Google Compute Engine. Installed successfully, working well with the mongo shell via SSH. Now I wanted to access the database remotely from my desktop.

Following this guide, I edited my /etc/mongod.conf file and commented out the bind_ip line in the following code:


port: 27017

# bindIp:

Restarted the service service mongod restart

Also opened the TCP port 27017 on the Google Cloud Platform Firewall.

However, the database is still inaccessible via all means, i.e. the mongo shell installed on my local machine, MongoDB Compass, the server_ip:27017 format on Google Chrome, all fail to connect.

I ran sudo netstat -tlnp via SSH on the VM,

I only got the following line for MongoDB:

tcp 0 0* LISTEN 18490/mongod

The line which should have been there indicating that it is open to all connections was still missing.

Can this possibly be a configuration error or is some internal firewall blocking the connection?

Edit: I even made sure iptables isn't causing this. Issued the commands

iptables -A INPUT -p tcp --destination-port 27017 -m state --state NEW,ESTABLISHED -j ACCEPT

iptables -A OUTPUT -p tcp --source-port 27017 -m state --state ESTABLISHED -j ACCEPT

Still no luck

Solved it. It was indeed a configuration problem and not a firewall issue.

Apparently MongoDB no longer works fine with bindIp: or commenting out bindIp entirely.

What worked is that I removed the bindIp line and replaced it with

bindIpAll: true

So the final code looks like:


port: 27017

bindIpAll: true

# bindIp:

P.S. If you're doing this on your server, don't forget to enable MongoDB authentication

Uncomment the line security: And add authorization: 'enabled' below that.


authorization: 'enabled'

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags