google-compute-engine"/>
  • 8
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I've been running a long job on GCE with a GPU. It is not a preemptible instance.

I was monitoring the job on a local terminal with SSH and TMUX on the instance so it keeps running if the SSH connection gets broken. The screen froze so I tried to SSH from another terminal window, but SSH also froze.

I went to the Google cloud console to try to see what is going on, and there are a lot of disk reads going on:

enter image description here

I'm pretty sure that nothing I've done has caused the disk reads.

Any idea what is going on? I hope my job is still running and I don't want to start over again so I'd rather not stop and restart my instance.

I think Womble is right that it is a memory and swap issue.

When the instance was working, I SSH'ed in and ran a small quick job, and I think that pushed the memory requirements over the edge. This condition lasted for hours so I stopped and restarted the instance.

When I started the job over from scratch the problem happened again. The job worked previously, so I'm going to wipe this instance out completely and create a new one from scratch and hope that it works again.

I can't increase memory because I'm already using the max.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags