google-compute-engine"/>
  • 4
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I have installed CouchDB in a windows server 2012 instance. It works fine and I can access the databases locally (localhost:5984/_utils). But when I try to access through the external IP, I've got 'This site can’t be reached... took too long to respond'... If I try only the IP address (without :5984) it returns IIS default page normally. I already tryied to put rules in firewall and even turn off firewall without success. [BTW: What is the difference of set External IP 'Ephemeral' or static (srv name)? (I also have tryied both)] Thanks !!! Evemar

      • 1
    • In CouchDB configuration file, what is the value for bind_address for port 5984? If it's 127.0.0.1 change it to 0.0.0.0, save and restart the CouchDB service.

This is most probably related to address binding. In CouchDB configuration file, what is the value for bind_address for port 5984? If it's 127.0.0.1 or localhost change it to 0.0.0.0, save and restart the CouchDB service.

Also, try checking the firewall settings of your GCE network to make sure that a rule is configured to allow traffic for TCP port 5984.

  • 1
Reply Report

what type of authentication are you using in IIS? Depending on your firewall you may need to create a custom protocol (Different than a rule) then call that protocol in a rule to pass the traffic. I've had to do that before.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags