google-compute-engine"/>
  • 4
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I am trying to configure a compute engine instance. No matter which zone/region I pick, it says the region is limited to 24 cores. I have an instance that somehow I edited to 32 cores, but whenever I try to start it, it says no resources available.

How do you get a high core instance ?

Thanks.

This sounds like it might be a quota issue. I assume that you have billing enabled; if you do not then you should sort that out first :-)

You can see your quotas by zone by going to the console and in the sidebar select "IAM & admin" > "Quotas" then in the drop down menus select Service "Compute Engine API" and Metric "CPUs."

I for example have a max of 24 cores in some zones, and 72 cores in other zones.

Note: if you have a quota of 72 cores elsewhere, and don't really care what zone you use, this would be the time to migrate to a zone with higher quota.

Assuming that the issue is that your quota is 24 in a zone you need 32 cores in, do the following:

  1. Select the zone with the checkbox on the left
  2. Click "Edit Quotas" at the top
  3. Fill out the form on the right
  4. Wait

Ideally, if you need 32 cores, approval should be quick. If you have a brand new project, or lots of cores in other zones, it might go to a human. In either case, please put in a reasonable justification.

  • 1
Reply Report
      • 2
    • Even if this is a brand new project approval should be quick. I'm editing my answer also: if you have a quota of 72 cores in another zone you could consider making an instance there.
    • It was the 'quota' settings - would be nice if the error message reflected that when trying to setup or start the instance - honestly struggled with it which forced me to come here... I've requested the upgrade (all of my zones list 24 as the max) Thanks !
      • 1
    • I just tried to make a too-big instance. In my instance list I got a little red exclamation mark icon. Hovering over the icon shows a tool tip "Quota 'CPUs' exceeded. Limit: 24.0 in region us-east1" -- do you not get the same?
      • 1
    • No. It let me change it fine. I get an error when I try to start "the zone does not have enough resources available to fuffill the request, try another zone or try again later"

It seems you have reached your quota limit for cores in that specific region. In my case I have some regions with a limit of 72 and others with a limit of 8.

I suggest under the IAM page in your project where it says "Quotas" verify your limit. For example you can filter it so it's much faster and easier to read.

Go to IAM -> Quotas then to filter:

  • Quota type = All quotas
  • Service = Compute Engine API
  • Metrics = CPUs
  • Location = All locations

There you can see the limits for CPUs(cores) for all of your regions and select one that has a limit of more than 32.

Just an FYI, If you need to ask for a quota increase your project needs to not be in free trial, so basically you would need to upgrade your account.

  • 0
Reply Report
    • Thanks. It was the quotas. As I pointed out in the comments to the other answer, the error messages don't seem to be correct when editing & starting an instance

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags