google-compute-engine"/>
Answer

It seems that your vm has stopped communication with the local metadata server. There are different reasons for this to occur. It could be if your machine experienced high CPU load, when the host machine experienced high CPU load it causes the networking to degreade. You can check the CPU utilization within the VM using ‘top’ command. If your VM is using high CPU than you can either, close the processes using the CPU or upgrade your GCE VM size. The steps to change the GCE VM size are documented here. Also it will be helpful if you allocate enough memory to your machine according to the utilization. Another possibility for this error to occur is when the GCE guest environment is not setup correctly. GCE linux VM has daemons running which are responsible for setting the guest environment. You need to make sure those scripts are running on your VM. You can use 'ps -aux | grep google_' command to confirm. This document has more information about setting Linux guest environment. Another easy fix would be to restart your VM which will start the GCE scripts during the boot process.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags

Related Questions