google-compute-engine"/>
  • 5
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I would like help in resolving the following issue...

"We are unable to connect to the VM on port 22. Learn more about possible causes of this issue."

After having stopped and restarted the VM because of the following issue below, the new issue above came up.

"Connection failed, An error occurred while communicating with the SSH server. Check the server and the network configuration"

I have tried the recommend ways of troubleshooting the issue via putty which did not work and the firewall seems okay.

Just wondering if they are any other suggestions of resolving this...

ADDITIONAL INFO AND UPDATES - Was following this tutorial(link below) to install NVM which caused the initial issue. I think I might have made changes to the user profile directory and bash files which is causing login issues.

https://github.com/creationix/nvm#install-script

  • I was able to recreate the problem, using another instance. So the /usr/lib directory was deleted. Any possibility of reinstalling the library files?
  • Did you tried to ssh to your server using the Developers Console? You just need to click on the button "SSH" on the right of your server's name.

  • If you successfully accessed to the server, try the following command on your local machine:

    $ gcloud compute ssh [INSTANCE_NAME] --project [YOUR_PROJECT_ID] --zone [YOUR_ZONE]

  • if you can't connect to your instance using gcloud compute ssh, you can enable the serial port and try to connect to your instance.

    $ gcloud compute connect-to-serial-port [INSTANCE_NAME] --project [YOUR_PROJECT_ID]

  • If you can't connect to your instance, please share with us the Serial console output. In the Developers Console select your server and from your VM instance page go to the bottom where you can see a link "Serial console output". Click on it.

  • 0
Reply Report
      • 1
    • Hi Miguel, thanks for your prompt response. So tried all of the above. Here is the serial output.. Failed to start Login Service. See 'systemctl status systemd-logind.service' for details. Failed to start System Logging Service. See 'systemctl status rsyslog.service' for details. Failed to start Apply the settings specified in cloud-config. See 'systemctl status cloud-config.service' for details. Failed to start Snappy daemon. See 'systemctl status snapd.service' for details. Started iSCSI initiator daemon (iscsid). Started LSB: MD monitoring daemon.

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags