• 3
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I am trying to install a PCI network card in a SunBlade 150 running Solaris 9. I have tried a number of different cards (D-Link, Netgear, Intel) and none of them "just work". Using prtdiag I can see the onboard interface which I do have working:

pci     33    +s/system-board  pci108e,1101 (network)        SUNW,pci-eri
              okay        /pci@1f,0/network@c,1

However, any PCI NIC that I plug into the motherboar shows up like this:

pci     33    +tem-board/PCI1  ethernet
              okay        /pci@1f,0/pci/ethernet

The word "ethernet" is a good sign, but there is no PCI ID listed, nor do I have the comforting "(network)" text.

I aleady tried ifconfig -a plumb as well as looking through kstat. What do I need to do to get one of these cards working? Do I need some special, proprietary Sun card? Appreciate any advice...

I solved this by doing the following:

  1. Found a network card that was compatible with one of the Free NIC drivers for Solaris. In my case, I had an Intel card that was compatible with the "em driver for intel gigabit ethernet controller 8254x".
  2. Downloaded the source tarball and following the very explicit directions I found in README.txt.
  3. Unfortunately my system had no compiler, so I had to install gcc from sunfreeware. As per the gcc instructions, I also installed libiconv.
  4. Once I had the ability to compile, the README.txt told me nearly exactly how to do everything else.
  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags