• 11
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I am trying to compile rsync-3.0.7 on Solaris 5.10 on an Intel chipset.

When running ./configure I see the following (obviously erroneous lines):

checking size of int... 0
checking size of long... 0
checking size of long long... 0
checking size of short... 0
checking size of int16_t... 0
checking size of uint16_t... 0

In config.log I see the following lines:

configure.sh:5448: /tool/sunstudio12.1/bin/cc -xc99=all -o conftest -g -DHAVE_CONFIG_H   conftest.c  >&5
"conftest.c", line 123: warning: statement not reached
cc: Fatal error in cc : Segmentation Fault
configure.sh:5448: $? = 1
configure.sh: program exited with status 1

Segmentation fault? What could be causing a simple test script to segfault during compilation?

This wont fix your compiling issues, but you could always look at using the opencsw repo http://opencsw.org/ they have this version of rsync already compiled and have a useful app called pkg-get for performing the installations

  • 1
Reply Report
      • 1
    • Good answer. To be honest I'm just recording what problems I've had and how I solved them on here because not only do I think I'll come across this again but I'm sure other people will too.

I ran into the same problem, but couldn't use the -xc99=all,no_lib workaround (the program I was building needed all c99 features) and tried manually running the cc command under truss. It showed the segfault happened just after trying to open /lib/values-xpg6.o. This file wasn't present, but is available in the SUNWarc package. I installed that and the segfault went away.

I'm not entirely sure what the root cause was, but that should help anyone for whom the above workaround fails.

  • 0
Reply Report

The option -xc99=all was causing the segfault. A description of the option can be found here which states that the default is -xc99=all,no_lib (which doesn't cause the compiler to segfault).

To make the configure script work I edited configure.sh it and replaced the instance of -xc99=all to -xc99=all,no_lib

Answered my own question so that others that encounter this issue may have a vector to try in establishing a work-around.

  • 0
Reply Report

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags