• 11
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /home/prodcxja/public_html/questions/application/views/question.php
Line: 191
Function: _error_handler

File: /home/prodcxja/public_html/questions/application/controllers/Questions.php
Line: 433
Function: view

File: /home/prodcxja/public_html/questions/index.php
Line: 315
Function: require_once

I place the following into an admin file called noask


mail=
instance=overwrite
partial=nocheck
runlevel=nocheck
idepend=nocheck
rdepend=nocheck
space=nocheck
setuid=nocheck
conflict=nocheck
action=nocheck
basedir=default


Then run pkgadd -a noask -d sed-4.1.5-sol10-x86-local - yet am still queried for:

'Select package(s) you wish to process'

Is there a way around the questioning without doing an "echo yes" at the front?

Thank you

You do not tell what package to install from the package datastream which might contain more than one package (although it doesn't in your case).

This should work:

pkgadd -a noask -d sed-4.1.5-sol10-x86-local '*'
  • 1
Reply Report
      • 1
    • @jlliagre This does not work for me when I install OpenCSW: root@solaris:~# pkgadd -a noask -d get.opencsw.org/now '*' ## Downloading... ..............25%..............50%..............75%..............100% ## Download Complete pkgadd: ERROR: no package associated with <*> root@solaris:~# It works if I explicitly pass the package name instead of an asterisk
      • 1
    • @AndriyYurchuk I guess it is because you are passing an URL, not a file as the question is about. It should work if you do it in two steps like 'wget .../now && pkgadd -a noask -d now "*"'

Warm tip !!!

This article is reproduced from Stack Exchange / Stack Overflow, please click

Trending Tags